Value does not fall within the expected range on Feature Activation


I created a feature for custom content type with three file.
1. Feature.xml
2. ContentType.xml
3. ContentTypeColumns.xml

When i installed this feature i get “Operatuion Completed Successfully” but when i go for feature activation it gives me error
i.e. “Value does not fall within the expected range.”
After i looked in to ContentType.xml, i found my ContentId contains hyphens(“-“) i just removed the hyphens save the file and it worked fine for me..

Wrong ContentId:
<ContentType
ID = “0x01080100-50912-cd256-284f2-0bb85-37257-294a474”
Name = “ContentTypeList CustomContentType”
Group = “Logimindz Content Types”
Description = “This is generated by one of Logimindz’s application”
Version = “0”
Hidden = “FALSE”>

Right ContentId:
<ContentType
ID = “0x0108010050912cd256284f20bb8537257294a474”
Name = “ContentTypeList CustomContentType”
Group = “Logimindz Content Types”
Description = “This is generated by one of Logimindz’s application”
Version = “0”
Hidden = “FALSE”>

Advertisements

One thought on “Value does not fall within the expected range on Feature Activation

  1. thank you very much for your solution,in my case i got same error,and it solved seems to be,i need to check in the List settings.thank you so much and keep posting any errors and solution.

    Hari

Leave a Comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s